_Browser Requirements

Using Lead Liaison's web application accessible via https://app.leadliaison.com requires Google Chrome 9.0+. The following list of web browsers are not supported but may be compatible:

  • Firefox 3.0+
  • Safari 5.0+
  • Microsoft Edge 42.17134+

    Microsoft Internet Explorer is not compatible with Lead Liaison. Using it may cause unexpected behaviors.

The above unsupported browsers pertain to accessing Lead Liaison's web-based application through https://app.leadliaison.com, which is different from supported browsers for Lead Liaison's tracking code. Lead Liaison's tracking code is supported on any browser that runs javascript.